Coder Perfect

With Resharper installed, keyboard shortcuts are not available in Visual Studio.


I have Visual Studio 2012 installed, as well as Resharper 7.1.1000.900 and StyleCop 4.7.44.

The issue is that since Resharper was installed, no shortcuts have been active.

For instance, I can rename using the ‘Refactor > Rename’ command. However, the shortcut Ctrl+R has no effect.

In ‘Resharper > Options > Environment > Keyboard & Menus,’ I selected ‘Visual Studio’ as the keyboard scheme.

Is it possible to turn on keyboard shortcuts? Thanks.

Asked by Julia

Solution #1

Reset all Visual Studio settings first (Tools > Import and Export Settings > Reset all settings), then go to Resharper > Options > Keyboard & Menus and re-apply the keyboard shortcut scheme.

Once upon a time, I had to do something similar.

Answered by Nick Spreitzer

Solution #2

For me, this worked.

Apply and Save / Resharper / Options / KeyBoard & Menus / None /

and then

Set to Visual Studio / Apply and Save / Resharper / Options / KeyBoard & Menus / Set to Visual Studio / Apply and Save

Answered by ND72

Solution #3

The same thing happened to me, and a reset didn’t help. Then I got some aid from the resharper community. It was a simple solution! I’m from Russia, so Russian is generally my default keyboard. I changed the default keyboard to English in the control panel | language settings | change keyboard. Then, in VS, reapply the settings: Apply the R# scheme in Resharper|Options|Keyboard&Menus. And the issue was resolved:)

Answered by Yuri Fedoseev

Solution #4

One day, I had a lot of trouble getting this one to function in VS2015. Everything worked OK after the initial installation, however when I came in this morning, my keyboard shortcuts were not working. It didn’t work going through Resharper’s Environment > Keyboard & Menus, and it didn’t work reinstalling Resharper. It didn’t help to delete every configuration from Resharper’s AppData folder.

So, what worked? Reset the keyboard by going to Tools > Options > Environment > Keyboard in Visual Studio and selecting Reset. After that, Resharper’s strategies would take effect.

Answered by Adam Skinner

Solution #5

Alternately, make sure Resharper is turned on. Because my Visual Studio didn’t update my Resharper licence information, there was a menu option “Why is Resharper disabled?” when I opened the resharper menu (after trying to find out why my shortcuts stopped functioning!). By selecting the menu option, a dialogue appears, which automatically resolves the licencing. Why do I have to enter the dialogue for the thing to automatically renew, Jetbrains?

Answered by InquisitorJax

Post is based on